在AMP插件版本升级到2.0.5以后,插件就不能用了,提示错误Error: An error occurred. You might be offline or logged out.

官方有个alpha版已经解决了该问题

Fixes #5537

Previously, we were including and if the class did not exist. This
worked fine in most cases, but it breaks when another plugin or theme
has previously imported . In this case, the AMP plugin does not import
as needed, and the required continues to not exist, resulting in a
fatal
error.wp-admin/includes/class-wp-upgrader.phpwp-admin/includes/file.phpWP_Upgraderwp-admin/includes/class-wp-upgrader.phpwp-admin/includes/file.phprequest_filesystem_credentials

For this fix, I wrapped the including of in a separate conditional. If
the function doesn't exist, the file is
included.wp-admin/includes/file.phprequest_filesystem_credentials

下载地址:
https://storage.googleapis.com/ampwp_github_artifacts/refs/heads/2.0/prod/amp.zip2.02.0.6-alpha

最后修改:2020 年 11 月 13 日 08 : 59 AM